Can't map 'Tab' as a shortcut


#1

Description of the Problem, or Question?

I’m trying to map ‘Fullscreen Mode’ to ‘Tab’, which is the same shortcut Krita uses.

Basic System Details

MyPaint version:

1.2.1+gitexport.bcf5a28d

Operating System + Version:

Archlinux. Cinnamon DE.

Make and Model # of Graphic Tablet:

Wacom Bamboo MTE 450

Please Tell Us How to Reproduce the Problem in Steps.

1 - Edit Shortcuts
2 - On ‘Fullscreen Mode’, try to assign the ‘Tab’ key as the shortcut.

Are there any Errors Popping Up? If so, paste the text in the area shown below.

Nope.


#2

Can you edit your accelmap.conf file located in ~/.mypaint/
and find the fullscreen line and make sure it looks like this:

(gtk_accel_path “/WindowActions/Fullscreen” “Tab”)

See if tab works now. If it doesn’t, then something might be intercepting the Tab keystroke (it works for you in Krita?). You might also try another desktop environment if you already have another one installed (usually you can select one before you log in). Hope this helps!


#3

FullscreenAutohide has ‘Tab’ mapped to it. Mapping ‘Tab’ to Fullscreen doesn’t do anything.

EDIT - Krita’s “Fullscreen” in this case is what they call “Canvas Mode” and is the equivalent of going Fullscreen, then hiding the menus in MyPaint. They do have a “Fullscreen Mode”, which is called with ‘Ctrl+Shift+F’, which does the same thing as MyPaint’s ‘F11’


#4

edit. So if Tab was still mapped to the FullScreenAutoHide-- that means you never successfully made the assignment for Tab=Fullscreen… hmm… So Tab works fine when you’ve already entered full screen; it hides the tools panels, right?

Is it only Tab=Fullscreen that is broken? That is, can you map Tab to something else like zoom or increase brush size, and does that work?

If nothing else, try remapping FullScreenAutoHide to something else, and then edit the file as I mentioned before and just set it. Let’s see if that at least is a work around and let us know where the error lies (possibly during assignment).


#5

Could you try these again with the mypaint-git package in the AUR(1.3.0.alpha.r4847.70ce73d9)? In my testing, I was able to reassigned Tab key, however if you just reassigned the FullscreenAutohide to another key map, tab key still works as well.

Also far warning, if you install gimp-git from the AUR, it will conflict with mypaint-git. They use a different version of libmypaint(1.3 instead of 2.0 with mypaint).


#6

@briend Done that. Tab doesn’t even do anything when mapped to where it’s supposed to be.

@odysseywestra Can’t do it from the interface and just remapping that manually will not produce the result I’m looking for.


#7

It’s working on my end(Tab=fullscreen, F11=FullscreenAutohide) so all I can say is do a complete reinstall of the mypaint-git package from the AUR. Also delete the config files as well. Hopefully that will clear the settings up to allow you to assigned Tab to fullscreen.

BTW, I’m on Gnome Shell with Antergos if that helps.


#8

Just for grins, can you check your keyboard with “xinput”?

open termnial and run xinput
find the ids for your keyboards in the list, then for each one run this (where 10 is the id):
xinput test 10

Then press the tab key a few times. You should see:

key release 36
key press 23
key release 23
key press 23
key release 23
key press 23
key release 23


#9

Well, it does work, but I can’t do both at once. Would be possible to have one shortcut that only hides the toolbars without going fullscreen?


#10

No sadly, as of right now we don’t have that functionality. You can thank the GTK3 devs for removing the ability of easily doing that sadly… @bleke did submit a Feature request for it though, so go ahead and vote for it. Also add your thoughts as well: Hide Controls in Windowed Mode

I’ll also fill out a bug report on MyPaint Github repo when I have time about the funky behaviour of the Tab key.