Error with InflateValidate in libpng16-16.dll on Windows 10 64 Bit

Tags: #<Tag:0x00007f73c23b2a08>

Description of the Problem, or Question?

Error with InflateValidate in libpng16-16.dll

Basic System Details

Windows 10 64 Bit
Intel Core i7 4790K
24 GB DDR RAM @ 799 MHZ

MyPaint version:
Version 2.0 64 Bit (Dec 19th Beta Build)

Operating System + Version:

Windows 10 64 Bit Build 18363

Make and Model # of Graphic Tablet:

None

Please Tell Us How to Reproduce the Problem in Steps.

I installed MyPaint 64 bit to my secondary internal HDD. Booting it produces the DLL error seen here:

dllerror

Are there any Errors Popping Up? If so, paste the text in the area shown below.

[Running python3.exe...
INFO: mypaint: Installation layout: conventional POSIX-like structure with prefix 'D:/Program Files/mypaint-git-w64/mingw64'

** (process:14112): WARNING **: 10:34:33.607: Failed to load shared library 'libgdk-3-0.dll' referenced by the typelib: 'libgdk-3-0.dll': The specified procedure could not be found.
Traceback (most recent call last):
  File "mingw64/bin/mypaint", line 309, in <module>
    from gui import main
  File "D:/Program Files/mypaint-git-w64/mingw64/lib/mypaint\gui\main.py", line 29, in <module>
    import gui.userconfig
  File "D:/Program Files/mypaint-git-w64/mingw64/lib/mypaint\gui\userconfig.py", line 20, in <module>
    from gui.compatibility import DEFAULT_CONFIG as COMPAT_CONFIG
  File "D:/Program Files/mypaint-git-w64/mingw64/lib/mypaint\gui\compatibility.py", line 12, in <module>
    from gi.repository import Gtk
  File "<frozen importlib._bootstrap>", line 991, in _find_and_load
  File "<frozen importlib._bootstrap>", line 975, in _find_and_load_unlocked
  File "<frozen importlib._bootstrap>", line 655, in _load_unlocked
  File "<frozen importlib._bootstrap>", line 618, in _load_backward_compatible
  File "D:/Program Files/mypaint-git-w64/mingw64/lib/python3.8/site-packages\gi\importer.py", line 145, in load_module
    importlib.import_module('gi.repository.' + dep.split("-")[0])
  File "D:/Program Files/mypaint-git-w64/mingw64/lib/python3.8\importlib\__init__.py", line 127, in import_module
    return _bootstrap._gcd_import(name[level:], package, level)
  File "<frozen importlib._bootstrap>", line 1014, in _gcd_import
  File "<frozen importlib._bootstrap>", line 991, in _find_and_load
  File "<frozen importlib._bootstrap>", line 975, in _find_and_load_unlocked
  File "<frozen importlib._bootstrap>", line 655, in _load_unlocked
  File "<frozen importlib._bootstrap>", line 618, in _load_backward_compatible
  File "D:/Program Files/mypaint-git-w64/mingw64/lib/python3.8/site-packages\gi\importer.py", line 146, in load_module
    dynamic_module = load_overrides(introspection_module)
  File "D:/Program Files/mypaint-git-w64/mingw64/lib/python3.8/site-packages\gi\overrides\__init__.py", line 118, in load_overrides
    override_mod = importlib.import_module(override_package_name)
  File "D:/Program Files/mypaint-git-w64/mingw64/lib/python3.8\importlib\__init__.py", line 127, in import_module
    return _bootstrap._gcd_import(name[level:], package, level)
  File "D:/Program Files/mypaint-git-w64/mingw64/lib/python3.8/site-packages\gi\overrides\Gdk.py", line 83, in <module>
    Color = override(Color)
  File "D:/Program Files/mypaint-git-w64/mingw64/lib/python3.8/site-packages\gi\overrides\__init__.py", line 195, in override
    assert g_type != TYPE_NONE
AssertionError
python3.exe exited with status 1.
Press return to close this window.
]

I cannot reproduce this on my VM, and other people have run the beta on Win10 successfully. The dependencies of the installs should be self-contained, so I don’t see how they got mixed up, if that’s what happened.

Have you tried installing it to your primary drive? If that works there’s something weird going on.

Try using this standalone build (currently the latest): https://ci.appveyor.com/api/buildjobs/ya3a7v44grkw8gj5/artifacts/out%2Fbundles%2Fmypaint-git-w64-2.0.0-alpha-master.598-standalone.7z

Download 7-zip if your archive program of choice cannot handle 7z, extract the contents to a folder and run the mypaint.exe within. It may take a little while to start (or maybe that’s just on VM’s).

For the record, reinstalled on C:, same DLL error, as well as the specific standalone version linked.
The specific version linked worked, but the one on site failed. Here’s the log for both, installed version followed by the successful standalone version:

Running python3.exe...
INFO: mypaint: Installation layout: conventional POSIX-like structure with prefix 'C:/Program Files/mypaint-git-w64/mingw64'

** (process:22232): WARNING **: 15:41:10.637: Failed to load shared library 'libgdk-3-0.dll' referenced by the typelib: 'libgdk-3-0.dll': The specified procedure could not be found.
Traceback (most recent call last):
  File "mingw64/bin/mypaint", line 309, in <module>
    from gui import main
  File "C:/Program Files/mypaint-git-w64/mingw64/lib/mypaint\gui\main.py", line 29, in <module>
    import gui.userconfig
  File "C:/Program Files/mypaint-git-w64/mingw64/lib/mypaint\gui\userconfig.py", line 20, in <module>
    from gui.compatibility import DEFAULT_CONFIG as COMPAT_CONFIG
  File "C:/Program Files/mypaint-git-w64/mingw64/lib/mypaint\gui\compatibility.py", line 12, in <module>
    from gi.repository import Gtk
  File "<frozen importlib._bootstrap>", line 991, in _find_and_load
  File "<frozen importlib._bootstrap>", line 975, in _find_and_load_unlocked
  File "<frozen importlib._bootstrap>", line 655, in _load_unlocked
  File "<frozen importlib._bootstrap>", line 618, in _load_backward_compatible
  File "C:/Program Files/mypaint-git-w64/mingw64/lib/python3.8/site-packages\gi\importer.py", line 145, in load_module
    importlib.import_module('gi.repository.' + dep.split("-")[0])
  File "C:/Program Files/mypaint-git-w64/mingw64/lib/python3.8\importlib\__init__.py", line 127, in import_module
    return _bootstrap._gcd_import(name[level:], package, level)
  File "<frozen importlib._bootstrap>", line 1014, in _gcd_import
  File "<frozen importlib._bootstrap>", line 991, in _find_and_load
  File "<frozen importlib._bootstrap>", line 975, in _find_and_load_unlocked
  File "<frozen importlib._bootstrap>", line 655, in _load_unlocked
  File "<frozen importlib._bootstrap>", line 618, in _load_backward_compatible
  File "C:/Program Files/mypaint-git-w64/mingw64/lib/python3.8/site-packages\gi\importer.py", line 146, in load_module
    dynamic_module = load_overrides(introspection_module)
  File "C:/Program Files/mypaint-git-w64/mingw64/lib/python3.8/site-packages\gi\overrides\__init__.py", line 118, in load_overrides
    override_mod = importlib.import_module(override_package_name)
  File "C:/Program Files/mypaint-git-w64/mingw64/lib/python3.8\importlib\__init__.py", line 127, in import_module
    return _bootstrap._gcd_import(name[level:], package, level)
  File "C:/Program Files/mypaint-git-w64/mingw64/lib/python3.8/site-packages\gi\overrides\Gdk.py", line 83, in <module>
    Color = override(Color)
  File "C:/Program Files/mypaint-git-w64/mingw64/lib/python3.8/site-packages\gi\overrides\__init__.py", line 195, in override
    assert g_type != TYPE_NONE
AssertionError
python3.exe exited with status 1.
Press return to close this window.
Running python3.exe...
INFO: mypaint: Installation layout: conventional POSIX-like structure with prefix 'C:/MyPaint Test/mingw64'
INFO: gui.main: No locale setting found, using system locale
INFO: lib.i18n: Windows: LANG='en_US'
INFO: lib.i18n: Windows: LANGUAGE='en_US'
INFO: lib.i18n: Value of LANGUAGE after cleanup: 'en_US:C'
WARNING: C:/MyPaint Test/mingw64/lib/mypaint/lib/gettext_setup.py: No bindtextdomain builtins found in module 'locale'.
INFO: C:/MyPaint Test/mingw64/lib/mypaint/lib/gettext_setup.py: Trying platform-specific fallback hacks to find bindtextdomain funcs.
INFO: C:/MyPaint Test/mingw64/lib/mypaint/lib/gettext_setup.py: Windows: found working bindtextdomain funcs in 'libintl-8.dll' (ctypes)

(mypaint:10608): Gdk-WARNING **: 15:47:44.607: gdk_input_wintab_init: WTOpen failed
INFO: gui.compatibility: Setting mode to 2.x (standard)
INFO: gui.compatibility: Setting default layer type to Pigment
INFO: gui.device: New device 'System Aggregated Pointer' (GDK_SOURCE_MOUSE, axes:2, class=GdkDeviceWin32, vendor=None, product=None)
INFO: gui.document: Initialized background from 'C:/MyPaint Test/mingw64/share/mypaint/backgrounds/mrmamurk/mamurk_e_1.png'
WARNING: gui.keyboard: Ignoring keybinding for '<Actions>/BrushModifierActions/BlendModeMenu'
INFO: gui.brushmanager: Switching default pigment setting to On
INFO: lib.document: load_ora: 'C:/Users/[User]/AppData/Local/mypaint/scratchpads/autosave.ora'
INFO: lib.document: 0.078s load_ora total
INFO: gui.filehandling: Loaded scratchpad from 'C:/Users/[User]/AppData/Local/mypaint/scratchpads/autosave.ora'
INFO: gui.compatibility: Setting default layer type to Pigment

I’m sorry, I don’t get what you mean here. It sounds a bit contradictory. Which version worked (paste the link) and which version do you mean by “the one on site”?

Sorry for taking so long to reply. I got sick around a week ago, am feeling better now.

The one that worked was:

https://ci.appveyor.com/api/buildjobs/ya3a7v44grkw8gj5/artifacts/out%2Fbundles%2Fmypaint-git-w64-2.0.0-alpha-master.598-standalone.7z

The one on site is referring to the GitHub build, at the time of me writing that post.

Ok, good to hear that you’re feeling better, and that the issue is at least fixed in the master branch.

I’m still not sure what the root cause of this problem was. If the issue was an import order, that error should have manifested for the other 1668 downloaders of that beta installer as well (assuming they used it), so it’s just surprising (though not entirely unbelieveable) that nobody else reported it.