MyPaint 2.0.0beta0 Fedora 33 Jam install lacking pressure sensitivity with Huion Inspiroy H640P

Tags: #<Tag:0x00007ff733506a90>

Subject states the problem.

Fedora 33 Jam

2.0.0-beta.0+unknown

Linux - Fedora 33 Jam

KDE Plasma

Huion Inspiroy H640P

Draw with stylus. Pressure sensitivity works with Krita 4.3.0, so this isn’t a driver issue, as far as I can tell.

Hi there,

  • Just to make sure: Have you tried different brushes that make use of pressure?
  • can you run gtk3-demo --run=event_axes and see if pressure is displayed as you press down the stylus?
  • Can you show us what is displayed on the window in “Help > Debug > Test Input Devices” as you slightly move/press the stylus inside the canvas area?
1 Like

Yes, I have tried what look like different brushes that use pressure. Completely new to MyPaint. gtk3-demo doesn’t exist on my system and I have no candidate to install. I have a screenshot, but the forum doesn’t seem to accept uploads…

I can however add, that the debug window says:

Pressure: (no pressure)
Tilt: (no tilt)
and
Barrel Rotation: (no barrel rotation)

Try running mypaint in terminal

unset GDK_CORE_DEVICE_EVENTS
mypaint

Fedora sets GDK_CORE_DEVICE_EVENTS for KDE sessions.
It was added in Fedora 22 as workaround for problems with scrolling in Firefox.
Added in Fedora bug: 1226465 – GTK applications (sometimes?) do not scroll correctly, lacks focus?
Variable is set in /etc/xdg/plasma-workspace/env/gtk3_scrolling.sh

Related mypaint bug: mypaint fails to detect tablet on fedora 22 · Issue #388 · mypaint/mypaint · GitHub

No change. Still the same problem.

Well, I finally got MyPaint working properly, but I had to go about it rather drastically. I erased my Fedora 33 install and replaced it with the latest Debian Buster Cinnamon (debian 10.7) with MyPaint 1.2.0+gitexport.f62444e. Now I can hopefully spend my time learning to draw and paint, rather than spending all of my time trying to get my computer sorted out. Thanks for the posts.

MyPaint's community forums is sponsored by Altispeed. Click here to visit their website.