MyPaint Crashing When I Drag Tools


#1

I filmed it happening: https://youtu.be/QVgcHZ2sYRs which basically explains it. I’m not trying to sound annoying or anything it’s just that it’s crashed like this every time I move any setting type thing from the side bar including brushes, layers box, etc. I just thought I should make a video of it happening in case it happens to anyone else.


#2

When you accidentally get a layers window, there’s a layers icon near the top of that window. See it? Try dragging that icon back to the side panel, does that work or is it still crashing?


#3

Yes, I tried that, it doesn’t move however, and just acts as if I’ve clicked it once (Whether I’m using a mouse or tablet) and so I can’t drag it with the icon.


#4

Strange. Which versions of MyPaint and Windows are you using?


#5

This might be this bug. You can try to install a different version of mypaint. Those are usually less buggy then the betas.


#6

Hi - the bug in the video is the one above, mentioned by @AnTi. It’s fixed ready for the next release, but I had to take a really heavy-handed approach due to some nasty shortcomings in one of libraries MyPaint uses, called “GTK”.

I had to disable snapping out subwindows on the Windows platform. :frowning:

The bugs and glitches in the current GTK releases (3.22.4-ish) make floating utility windows basically unusable, to the extent that I don’t want to ship with the feature enabled on Windows MyPaint right now :cry:

  • Vertical offsets between where you click and the effect it has in the subwindow
  • The thing with the crashes and the close button(s) is related, but not a showstopper
  • Total inability to resize the floating window properly. Ugh.

Thankfully, the tools still work when they’re docked in a sidebar, and you can drag them around still (with some careful thought, on Windows, because the little floating preview of the tab you get when dragging? Welded to the top left of the screen. gah!)

(And it all works so well in Linux… :penguin:)

(On the Windows GTK front, I did just kill off a load of upstream tablet bugs though. Things are moving along, albeit a little slowly)