MyPaint v2.0.0 not opening

Hi, I’m on Windows 7.
I’ve tried to install newer versions of MyPaint like v2.0.0
But my PC refuses to open it so I can’t try it. I wondered if it has something to do with “GTK” whatever that is.
Or could it be my PC is aggressive with file permissions and stuff?

I tested MyPaint 0.9, 1.0, 1.2.0, and 1.2.1, they all open fine. But MyPaint v2.0.0 does not open (I even tried 64 bit, 32 bit and portable zip versions).

It seems like I’m the only one with this issue, making me think it’s my Windows settings or something at fault.

It might have something to do with
GTK or file permissions.
Any ideas what I could try out to make it open?

Try executing mypaint from the command line (cmd / powershell) and provide the whole output.

Maybe that logs some usable information / error messages, that someone can help you with.

Please help !!

I’m not sure how to run MyPaint through CMD.
I tried typing and entered cd and then the folder location address
and then typed and entered start mypaint.exe
but it doesn’t start, just like opening the exe myself also does nothing.

Anyway I opened mypaint-debug.exe and I think I’m getting the same or similar error to oscar.
It starts with ERROR: specialized win32 argument handling failed. Something about line 113 and line 457 just like Oscar’s screenshot!

So apparently I’m not alone with this problem! :face_with_monocle:

Any idea what the problem is? I’m using the 64 bit version on a 64 bit Windows 7 machine, so why is it talking about win32? :hushed:

EDIT: this might be a similar (probably not the exact same) problem:

It mentions the win32 argument handling failed thing although that person’s issue was on Windows 10 and with different lines of code (not line 113 and 457).
That problem also involved an installed version but I’m using a portable version (installed version didn’t work either for me).
So it might be python that’s the issue??

The win32 bit is part of the error message, it does not actually refer to 32-bit windows. Win7 is not officially supported, and the windows build will keep being secondary unless someone is willing to handle that part of the development. I try to make sure that things build and run reasonably well on supported versions (i.e. Windows 10), but not more than that.

I know it can be inconvenient to upgrade, but if it’s at all possible for you, you should consider it.

Thanks for the reply. No problem with open source Linux being the priority OS, I respect that.
But it’s definitely not Windows 7 at fault (well possibly my configuration but not the OS itself). I would consider windows 10 a serious downgrade anyway (slow because of telemetry, bloatware and does not respect the user’s privacy!) :thinking:
I have seen videos of people on Windows 7 using the latest MyPaint. :flushed:

But anyway I think it could be an issue with python and maybe file permissions (aggressive security settings? Aggressive anti-virus? Maybe I disabled a windows service I shouldn’t have? :laughing:).
The portable version of MyPaint should have its own version of python but somehow it’s not working on my system (if it’s python that’s the issue, which I’m not completely sure of).
I currently do not have Python installed, although I doubt it will make a difference even if I did.
I might as well give it a try.

Hopefully someone comes up with more suggestions we could try out. :slightly_smiling_face:

In that case I will make an exception in this case. The error itself looks like it’s caused by a file path not being handled correctly, so perhaps it’s not so hard to reproduce (and fix). I will take a look this evening (CET).

I can’t reproduce this with the standalone 32bit version of 2.0.1, on a 32bit Windows 7 VM (microsoft don’t have 64bit ones available, for whatever reason). I don’t get the argument handling error and it starts just fine. I wonder if it’s related to the locale, or possibly location or drive letter.

What language settings do you use, and which package did you use when you ran the mypaint-debug.exe (standalone or installer)?

Thanks jpll. “Region and Language” somewhere in control panel, is that what you mean?
I tried changing the format to English (United States), English (United Kingdom), English (Australia)
but MyPaint 2.0.1 still doesn’t start.
Oscar (who has the same problem) appears to be using an “es” (spanish) language settings in Windows according to his CMD screenshot, if that helps figure something out?
Tried both installed and and portable (standalone) versions, same debug error.

I wonder if it has anything to do with dual booting.
I also notice in the CMD error it mentions it failed to load a settings file from a file location that includes the appdata folder. Maybe it doesn’t have permission there?
Let me know if I can try anything else.

Ok, good info. There is an old issue in the tracker where someone had problems when running the program on a drive/partition with a drive letter that was not C:\ and I have not tried reproducing that one.

The settings file is probably a red herring. It will show that message if there is no settings file already stored, and will write a new one on shutdown (proper shutdown, here it doesn’t start at all).

If all else fails, adding a flag to disable localization altogether could be an option here (if the problem is actually related to that).

Hey! I finally got it working guys! :smile:

I uninstalled python (I think it must have been too old or an incorrect setting or configuration).
Then I installed a newer version of Python that was compatible with Windows 7 (e.g. Python 3.8.7).
But it said it first requires the KB2533623 Windows update (so install that and restart when done).
Now MyPaint V2.0.1 opens for me.
When I installed the newer version of python, I installed “for all users” and also selected “Add Python to PATH” (I wonder if this was the real problem) if that matters.

I just wish MyPaint would one day allow “undo” to only undo one brush stroke at a time (instead of two)
but I understand there isn’t enough demand or there aren’t enough coders or resources so I may have to just get used to it until there’s more people able to help you guys (or if I had money I’d donate to help out :wink:).
I hope this helps others.
I should probably test other new versions of MyPaint but for now I’ll mark this as solved. :grin:

Hey Oscar, I’m replying because I solved my problem similar to yours, so maybe it will work for you.
It’s worth a try. :slightly_smiling_face:

I’m glad you found a solution. I wonder if the KB2533623 update is what actually fixed it, seeing as the mypaint windows package includes a bundled version of python that it will use, and that version would have been 3.8.x for 2.0.1 (3.9 was released later in 2020). Regardless, if it works that’s what’s important.

MyPaint's community forums is sponsored by Altispeed. Click here to visit their website.