Mypaint w64 1.2.1 and Huion H430p issue

graphic_tablets
Tags: #<Tag:0x00007fc0823bb948>

#1

Under Windows 10 Pro.
My H430p Huion tablet doesn"t work with Mypaint - latest version (but works perfectly with other program like windows Ink, Autodesk skectbook and with my Wacom Bamboo). I have the latest driver (14.5).
Works with my mouse.
I can see the cursor though but it never changes : always the circle, no arrow when I get out of the canvas and goes to the menu…
Any idea ?


#2

You could try an alpha build, please let us know if that helps:

https://ci.appveyor.com/project/achadwick/mypaint/build/1.3.0-alpha+master.354/job/mvdmswgmjqgw6gy3/artifacts


#3

I have just signed up as I am having similar issue.

Just purchased Huion H950P last Friday. Installed drivers, downloaded 14.5 and was successfully using MyPaint that night. Under devices the Huion tablet showed up and I have about 3-4 hours of use.

As this tablet is meant to work with Tilt, I thought I would try find out what programs would work and unknown if MyPaint supports it. Found out a Firmware upgrade is required for the Tablet and found the download for it. The firmware did not work for me. Then the Huion application had an update which I downloaded 14.7.x. Since then MyPaint closes as soon as I try to draw. Mouse works fine but Tablet closes MyPaint.

I found an old article in 2016 where someone had a similar issue and there were instructions on how to resolve but I can find that article again (I didn’t note the link).

I have contracted Huion and they send me an updated Firmware patch but this has not resolved MyPaint issue. I have uninstalled reinstalled Huion drivers and MyPaint. Even tried the stand alone version. Downloaded and installed both onto my laptop which I have not used either. Same issue still applys.

I had not downloaded GIMP so did that. Tablet did not immediatly work. Found under devices only Aggregated Device is available which is also what shows in MyPaint. But in Gimp I was able to add the HUION tablet and erasor which allowed me to use my Tablet. MyPaint does not have this feature.

So I have created an account and logged in here to post this issue as I have not found a solution.

From the little use I had of MyPaint I really enjoyed it and want to get back into it.

Can someone please point me in the right direction. Is there anything I can do to get this working again?

I will also try this Alpha version that has been listed.

Update: alpha does same. It actually doesn’t even load.


#4

Can you retry with the latest alpha?
https://ci.appveyor.com/project/achadwick/mypaint