Pressure not working, serial intuos windows 8

pressure
wacom
graphic_tablets
windows
Tags: #<Tag:0x00007fd757fd81b8> #<Tag:0x00007fd757fd8078> #<Tag:0x00007fd757347f48> #<Tag:0x00007fd757347e08>

#1

Hello,

I am using an old wacom serial tablet, Intuos GD-0912-R, with an Serial
to Usb adapter, prolific PL2303 (used driver
PL2303_Prolific_DriverInstaller_v1_11_0), and win 8.

Only 32 bits apps do have pressure working.
However the pressure is working fine on Gimp, Krita and Blender (all 32 bits).

On the previous versions of Mypaint, e.g. 1.0.0 (32 bits), the pressure was also working fine.

But on the new 1.2 (32 bits), the pressure is not detected :frowning:

On the Input device test, it shows “Device: WACOM Tablet Pressure Stylus”, but also “Pressure: (no pressure)”

(I tried to launch the axischart.py python app, to know if I would get
the same error from another gdk3 app, but get the error: EOFError:
[Errno 10054] An existing connection was forcibly closed by the remote
host)

The wacom driver used is the 6.1.0-6, from 2008, as on further drivers
the serial port was not implemented anymore (few tricks have to be used
to let it work on windows 7 and 8, as quickly described in this page: http://7fttallrussian.blogspot.fr/2013/04/how-to-get-serial-wacom-tablet-to-work.html)

The installer of the driver contains wintab32.dll version 1.0.4-1, which
is installed on windows as C:\Windows\SysWOW64\Wintab32.dll, and it’s
the one mypaint 1.0.0 is using when running. (and also used with the
1.2.0 version, but without providing pressure)

Anybody on the same boat or with an idea?

Thanks


#2

Related Issue Report on Github:

Moving to Github Issues Feedback.


#3

(I duplicate the infos put on the related “bug” report, in any case someone with the same situation would pass by here)

I also didn’t report the bug on gtk yet, because it’s working on krita
and gimp (and on mypaint 1.0), so maybe there is a lib or part of the
code where I could spot the difference…

I got axischart.py working (https://gist.github.com/achadwick/54e5b111e5ac908becf1) with a fresh install of python 3.4 and gdk 3.18.6 (via pygi-aio).

The x and y are showing black curves/area, but the pressure, xtilt, ytilt and whell are not showing any info.

It is also running with python 2.7 and gtk 3.0.0, with the same result (x y ok, nothing on pressure tilts and whell)

Would anybody know any test, e.g. in Python, I could do? (I am thinking of
digging inside the code of mypaint 1.0, or in gimp or krita…)

thanks