Support for Ubuntu 14.04LTS to be discontinued


#1
MyPaint’s testing repository for Ubuntu systems will discontinue support for an important old Ubuntu release shortly. Ubuntu 14.04LTS, a.k.a. “Trusty Tahr”, will no longer be supported by us. If you are using this Ubuntu release, please upgrade to the latest LTS, 16.04 “Xenial Xerus” as soon as you can. Here’s how. As you probably know I’ve been maintaining the Ubuntu mypaint-testing PPA for several years, trying to support a broad range of Ubuntu releases. We currently have support for trusty (12.04LTS) thru xenial (16.04LTS) with the notable gap of utopic (14.10) right now. Shortly, support will be dropped for vivid (15.04) too. This widening gap of support is happening because Canonical themselves do not support these old non-LTS releases: check out the support matrix on Wikipedia to see how they do it. Vivid has recently turned red, now that 16.04LTS is out, and we’re forced to maintain that pattern as it changes over time. Also, I actually want to discontinue making builds for the old LTS release for the next MyPaint 1.2.1.beta release or 1.2.1 proper, because supporting a 2 year old GTK platform makes development difficult and slows down the release process. It will mean we can rip out some very stinky old code that’s just there for legacy support ☺ Looking at the PPA’s download statistics, the majority of our PPA users are still wedded to the old LTS, so it’s clear we need you give folks fair warning. However, our hands are tied about the timing; I cannot see Canonical keeping PPA support for the old LTS around for much longer. People using Ubuntu 14.04LTS should upgrade to 16.04 as soon as possible. LTS→LTS upgrades are supported by Canonical. People using earlier Ubuntu releases should begin their upgrade treadmill now. You might be able to skip releases, but please check their release notes before you try anything drastic:
  • http://www.ubuntu.com/download/desktop/upgrade
  • https://wiki.ubuntu.com/XenialXerus/ReleaseNotes (15.10 or 14.04LTS)
  • https://help.ubuntu.com/community/UpgradeNotes (intervening versions)

This is a companion discussion topic for the original entry at http://mypaint.org/blog/2016/05/03/support-for-trusty-to-be-discontinued/

#2

This is a shame because I don’t plan on upgrading. (I use Ubuntu 14.04 on a bootable USB stick and upgrading isn’t really an option.) However, I’m sure i’m in the minority. I totally understand and support your decision. :smiley:


#3

#4

This widening gap of support is happening because Canonical themselves do not support these old non-LTS releases

This seems to be a misunderstanding:

According to the very page you linked, 12.04 is supported until 2017-04-26 and 14.04 is supported until 2019-04.

Many users like to have stable operating systems for more than a couple of years and still run bleeding-edge applications on them. The latest versions of Firefox from mozilla.org, for example, still run on very old Enterprise OSes.

Policies like these really make it unnecessarily difficult to use desktop Linux. Please target debian oldstable or CentOS 6; if you do, it will run on newer versions almost automatically; but not the other way around.

Thanks for your consideration!