Ubuntu Studio will drop MyPaint from the default installation


#1

’ Among those applications upgraded in this release is GIMP 2.10, which saw its release shortly before the release of Ubuntu Studio 18.04. Due to a library conflict between GIMP 2.10 and MyPaint, we had to make the hard decision to drop MyPaint from the default installation of Ubuntu Studio, citing other tools, such as Krita, as filling a similar role in graphical art production. As such, if both are installed and you wish to upgrade to Ubuntu Studio 18.10, you must uninstall GIMP or MyPaint for the upgrade to be successful. We apologize for this inconvenience. At this time, we are waiting for the upstream developers of MyPaint to release a new version based on libmypaint 1.3 before both can be co-installable again.’
https://ubuntustudio.org/2018/09/ubuntu-studio-18-10-cosmic-cuttlefish-beta-released/

Flatpak will work, I guess.
But, MyPiant version based on libmypaint 1.3…when?


#2

@Jehan has been very helpful and patient with MyPaint’s lack of active developers at the moment. I’m hoping I can step it up and help with maintenance more instead of just tinkering with the engine. But really, we need help; spread the word! :slight_smile:


#3

Well both Gimp and MyPaint are available as Flatpaks. so one or the other as a Flatpak solve it.
I have Gimp 10 as a Flatpak in Ubuntu Studio 18.04 now, because i had problem installing Gimp 10 with MyPaint.

You could at least write some INFO about ‘libmypaint 1.3 and MyPaint/Gimp10’ problem on you installation page (Linux). :slight_smile:


#4

Ahahah! Thanks for the nice words, @briend.
Anyway yeah, we work on improving libmypaint release. :slight_smile:

I am also hoping to have you at LGM so that we could work together more on this (perhaps). Be prepared to be invited by GIMP (and book your dates!). :wink:


#5

That’s exciting! I have a lot to learn before I can be helpful, I think :slight_smile: