Which Graphic Tablets Models Work on MyPaint 1.2.0+?

hardware
graphic_tablets
faq
Tags: #<Tag:0x00007f14c6d64a98> #<Tag:0x00007f14c6d64930> #<Tag:0x00007f14c6d647c8>

#21

Hello,

EDIT: I unplug my tablet and use the laptop touchpad and the program work fine. But when I plug it back my tablet, MyPaint start to be unresponsive and the cursor is offset. See video link. Video

XP-Pen Star 03 Series Tablet works. The cursor is offset.

__
Off Topic:
I download both 64 bit and 32 bit from Github, neither of the program won’t open after Installing. So I tried I downloading MyPaint from the PortableApp, the program did open, but it is not responsive. I had to use Task Manger to close it. (See video)

OS: Windows 10


#22

I had a similar problem and solved it by uninstalling python 3 and installing python 2, then installing the 32 bit version which ran ok.


#23

At least on Debian Sid Mypaint 1.2.0 is broken on Huion H610 Pro.

GDK 2.35.4
UPDATE: See Below:

GNOME 3.21.91.1

The Huion works in Inkscape, Gimp 2.8.16, but the pressure freehand and the inking outputs clear to the screen. Every other output works.

Oddly, or not, the same behavior in Krita 3.x on Linux. Works great on OS X because OS X has proper support.

So what library is MyPaint sharing with Krita that deals with pressure sensitive brush that is not being shared with Gimp or Inkscape?

UPDATE: GNOME 3.22

After a painful backup and clean reinstall of Debian from the freshly minted Debian 8.6 DVDs I then updated the entire system to use Debian Sid and GNOME 3.22/KDE 5. Several hours later and slowly getting all aspects to play ball [I would recommend for the novice to wait until PERL 5.24 is fully baked into Debian before attempting] I noticed a few Xorg packages were removed: namely VMMOUSE.

You’ll notice that there is exactly 1 reference to the Pen and Control. The scribbling is success. So, no DIGI drivers needed. Just straight evdev out of the box and libinput to the latest Xorg in Debian Sid, which upon updating dropped the vmmouse driver modesetting driver.

RECOMMENDATION: HUION 610 Pro fully works. I can work on customizing the Control settings later as I am just happy I got it to just work.


#24

Hi,
I use a Bosto22HD tablet. In fact I try as much as possible to support the Bosto tablet with a driver for Linux, this can be found here:

It works with Mypaint pretty good. Although I’m currently having problems with Ubuntu 16.10, something has changed in the xorg-evdev drivers and its screwed up pressure data. Working on it. So for now, 16.04.1 LTS is good to go and the driver works fine.


#25

Linux Mint: Debian edition ~~ Bamboo Pen - CTL-460
(I know a couple of the other Bamboo models were mentioned already.)
It does fine on windows as well.


#26

Wacom Bamboo Fun cte-650 on Windows 7 doesn’t work for me. Pressure sensitivity is not there and it’s not listed with the device.
Works with Sai and Krita, but no version of mypaint so far.


#27

Genius i405X works nicely for me ^^ (Windows XP Pro 32B / Windows 8.1 64B)…


#28

Hello everyone. MyPaint v1.2.1 was released recently (ohboy, still need to write an announcement about it!) and it contains fixes for a lot of tablet bugs and crashes in its Windows bundle.

I’m questioning how useful it is to maintain this information without any reference to a MyPaint version number, or the version of GTK that was used. Tablet support is critically dependent upon a lot of things; in order of importance: GTK version, OS+version, driver+version, X11/Wayland.


#29

The post is set as a wiki so anyone can edit it as long as they are logged in and at least trust level 1. As long as its kept up to date, we shouldn’t have any problems keeping this list handy.


#30

I use Linux Mint 18.1 (mate) 64bit. I did not even have to calibrate my drawing tablet. The pen model I have is an older version. It’s a Wacom Bamboo PEN model CTO-460 wired via USB hub. Although it works just fine with Kita and My paint both. This is on Dell Optiplex 780 (4gb ram), which is dual booted Win10 and Linux. I have not tried it in windows as I prefer my Linux O/S. The only reason I ever boot into windows is to check compatibility with Microsoft office 2010 application formats.


#31

I had to tinker with it initially but all I needed to do was follow the instructions on the Wiki

Trust TB-1200
Ubuntu 16.04
(Possibly older versions)
Windows 7
(Possible but configuration necessary)


#33

I can’t edit the wiki post, but I’ll still try to contribute.
I use a Windows 10, 64-bit system on both PCs I use MyPaint on, and I use MyPaint 32-bit with most, if not, all the stable releases of MyPaint. All the screen tablets I’ve owned that are listed can only be used in Single Screen mode on Windows, not extended.
-Yiynova MVP10U (screen tablet)
-Artisul Pencil (non-screen tablet)
-Ugee HK1560 (screen tablet)
-Microsoft Surface 3 (Tablet PC) - the alpha builds seem to fix pressure issues in the 32 and 64-bit versions, but pen pressure doesn’t work with either version in the current 1.2.1 release (as of Dec. 2017.)