Windows focus issue


#1

Description of the Problem, or Question?

When MyPaint idles for some minutes and you attempt to go back to your work the program freezes.

Basic System Details

MyPaint version:
1.3.0-alpha+git.0b19fce4

Operating System + Version:
Windows 10 x64 (Windows Ink)

Make and Model # of Graphic Tablet:
Wacom PTH651L

Please Tell Us How to Reproduce the Problem in Steps.

It always happens like that:
Draw something for a couple of minutes, minimize or take away its focus for say 10, 15 minutes and after that try to put focus on the program window.


#2

Does it freeze forever and you have to terminate it?


#3

Exactly



#4

Can you try reproducing it with just the mouse? Unplug the wacom totally and reboot and see if a mouse drawing will cause it? Do you have a touchscreen monitor?


#5

This bug is difficult to pinpoint. Sometimes it’ll idle for a long time and work flawlessly when it receives the focus again. Other times you work on something else for just a couple of minutes and it’ll freeze after receiving the focus again (I can’t tell whether it froze the exact moment it got the focus or before, though).

Also, sometimes instead of freezing the pen pressure stops working. (don’t know if it’s related)

I unplugged the Wacom for a couple of hours and it hasn’t frozen so far.

And not using a touchscreen monitor.

EDIT2: It seems that when this issue happens, the mouse gets totally blocked in the interface (you can move the cursor but cannot click on anything), but the stylus pen keeps working. The keyboard also works.


#6

Another bug (don’t know if it’s related): The 1st time the program is run after system start the pen pressure won’t work. It’s necessary to relaunch the program to fix it.


#7

Can confirm both bugs.

MyPaint Mouse & Tablet input freezes completely occasionally. Sometimes when the windows receives focus, but also sometimes if I change the brush. Always have to close MyPaint with keyboard controlls and restart it.

The second bug (No Pen Pressure after first start) is due to not recognizing the wacom tablet until it is used some seconds after start of MyPaint. It will not be shown in the “Devices”-View of MyPaint until you put the stylus on the tablet approx. 5 seconds after MyPaint has started.